ssh connection error Authentication refused: bad ownership or modes for directory

Connessione automatica ssh tra un server aix 5.3 e una Red Hat Enterprise Linux AS release 4 (Nahant Update 1)

Dopo aver esguito i soliti comandi indicati nei miei post precenti non mi funzionava la
connessione automatica con le chiavi RSA tra i due user oracle dei due server nella direzione AIX –> RED HAT

Dai log secure sotto /var/log/secure della redhat :

Jul 2 00:31:18 ceprv01 sshd[10026]: Authentication refused: bad ownership or modes for directory /usr/oracle

Alla fine ho risolto mettendo a posto i permessi della directory home /user/oracle del server redhat perche’ questi (ahime’) avevano permessi 777 (troppo open per ssh) percui una volta settati con chmod 755 la connessione e’ funzionata senza problemi

Mi e’ stato molto utile utilizare il commando verbose dell’ssh :

ssh -vvv “server”

ssh connection error Authentication refused: bad ownership or modes for directory

Versione FW su pSeries

Per vedere la versione del Firmware dei componenti di un pSeries utilizzare il comando :

lsmcode -A

l’output sara ‘:

sys0!system:3K060109 |System Firmware:RG060109_d79e15_regatta
hdisk0!ST37345.53583233.43353137
hdisk1!ST37345.53583233.43353137
fcs1!df1000f9.393100
ent0!1410ff01.SCU015
ent1!14106902.GOL001
ent2!14106902.GOL001
ses0!A0900724.0015
ses1!A0900724.0015
fcs0!df1000f9.393100

Versione FW su pSeries

Virtual Machine Xp per VDI

Per installare XP su una virtual machine ospitata da un ESX 3.5 ho riscontrato un problema nel far vedere l’HD virtuale all’installazione di XP.
Il tutto risolto aggiungendo un dirver, utilizzando l’apposito procedimento di XP per aggiungere driver di terza parti e scaricando l’immagine del floppy contente il driver dal sito di VMWARE :

http://download3.vmware.com/software/vmscsi-1.2.0.4.flp

Virtual Machine Xp per VDI

Pulizia PostgreSQL di Puremessage

Export DB, Drop DB, Import DB-

Dall'utente pmx :

set -a
PATH=$PATH:/var/pmx/postgres/bin
PGDATA=/var/pmx/postgres/var/data
PGUSER=pmx
PGDATABASE=pmx_quarantine
pg_ctl stop -mfast
PGPORT=5433
pg_ctl start -o "-p$PGPORT" -l /var/pmx/var/5433.log
time pg_dump -Fc >/var/pmx/var/pmdb.zdump
dropdb $PGDATABASE
createdb $PGDATABASE
time pg_restore /var/pmx/var/pmdb.zdump | psql -qet>/var/pmx/var/load.log
2>&1
time vacuumdb -vz 2>/var/pmx/var/initvac.log
pg_ctl stop
unset PGPORT
pmx-database start

Pulizia PostgreSQL di Puremessage

HW clock

Ecco alcuni comandi per gestire l'HW clock di un server LINUX :

hwclock –show

Visualizza l'hwclock del server

hwclock –hctosys

sincronizza l'ora del sistema operativo con l'HW clock

hwclock –systohc

sincronizza l' hw clock con l'ora del sistema operativa

HW clock

Ip alias su AIX

Come vedere se e' presente un IP Alias

root@candy>lsattr -El en5 -a netaddr
netaddr 10.56.x.5 Internet Address True
root@candy>lsattr -El en5 -a netaddr -a alias4
netaddr 10.56.x.5 Internet Address True
alias4 10.56.x.100,255.255.252.0 IPv4 Alias including Subnet Mask True
root@candy>

Come aggiungere un ip alias :

ifconfig en5 130.35.13x.xx netmask 255.255.252.0 alias

Come rimuovere un ip alias :

ifconfig en5 delete <ip alias>

Per chi vuole utilizzare smitty :

smitty inetalias

Ip alias su AIX